←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
amette_left #tikiwiki [00:58]
joined #tikiwiki
left #tikiwiki
joined #tikiwiki
[01:08]
............................................... (idle for 3h52mn)
Tiki|botNew Forum Posts: Feedback Methods Vote - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57630
New Forum Posts: Problems in Tiki14 using SEFURL and non-Engish page names - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57629
New Forum Posts: ZF1 to ZF2 Migration ready to merge to trunk - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57626
[05:00]
New Forum Posts: Feedback Methods Vote - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57630
New Forum Posts: Problems in Tiki14 using SEFURL and non-Engish page names - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57629
New Forum Posts: ZF1 to ZF2 Migration ready to merge to trunk - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57626
[05:10]
......... (idle for 43mn)
amette_left #tikiwiki
joined #tikiwiki
[05:53]
..................... (idle for 1h44mn)
Telesightjoined #tikiwiki [07:37]
GillesMjoined #tikiwiki [07:40]
.................. (idle for 1h28mn)
redflojoined #tikiwiki [09:08]
chibaguyjoined #tikiwiki
polom
[09:22]
I want to do something simple involving wiki pages, themes and perspectives, and it doesn't seem to be working: make a perspective, add to it a homepage and a theme.
Why doesn't the theme switch at that homepage?
(This is in trunk)
Is it necessary to turn on or off any other feature or setting, to avoid conflicts, or something?
I've tried theme control on and off, "user can switch theme" on and off, category jail, categorize page, etc. in various ways
Seems like this used to work easily and smoothly.
Or am I still sleepy from the weekend? ;-)
Perspectives doc page is another case of badly needing improvement.
[09:36]
............ (idle for 59mn)
Ok, partly a misunderstanding on my part. Just going to the homepage specified in the perspectives
in the perspective's items doesn't switch the perspective for the user except for on that page.
To get a "permanenet" perspective switch, the user needs to do something like click the "switch-perspective" link.
[10:40]
................. (idle for 1h21mn)
olinuxxjoined #tikiwiki [12:03]
macnificjoined #tikiwiki [12:12]
..... (idle for 21mn)
chibaguyAbout the perspectives and themes question I posted earlier, navigating to a page that, in a perspective's definition, is the site homepage, and this perspective also has a theme set, the theme isn't being used, which is wrong. [12:33]
Looks like both perspectives and theme control need to be used to do this: be able to switch the default theme but preserve object-specific themes.
(that is, I want to use perspectives to both switch the theme and some oject things like homepage, but I don't want to impose the theme on all objects, some of which have their own theme.)
[12:40]
........... (idle for 50mn)
jonnybjoined #tikiwiki
pompom polom
[13:31]
......... (idle for 40mn)
arildbjoined #tikiwiki [14:11]
amette_polom [14:12]
jonnybpolompom amette_ [14:14]
amette_bolowbow jonnyb :) [14:15]
jonnyb:) [14:15]
arildbHi jonnyb [14:23]
jonnybhi arildb - nice to see you back in TikiLand :) [14:24]
arildbAbout the prefslib update I did. If you want to I can find out which pref it is that is causing the problem. However, right now I don't have time to go "further up the chain" to possibly correct it there. [14:24]
jonnybdon't worry, i understand [14:25]
arildb:) [14:25]
jonnybwhere was the error occurring? [14:25]
arildblet me check [14:25]
It occurs in the admin wizard, pafe "Set up look and feel" Save and Continue. The violating pref is an empty pref. Multiple occurences [14:31]
jonnybah, yes, the wizard is a mess, so much copy and pasted code so can't really be maintained (i don't have time) [14:32]
arildblol [14:33]
jonnybshame, cos it's really useful - just when things change there's so much work to alter it, and no one around doing it ;( [14:33]
arildbIt looks pretty good to me from a the user perspective. [14:34]
jonnybi guess just hiding the errors has to be done for that if it's not going to get fixed [14:34]
arildbIf something more "severe" occurs let me know, and I will see if I can find time [14:34]
jonnybtehre were huge changes in 13 and 14 for themes and iconsets, which didn't get done in the wizard pages afaik [14:35]
arildbyes...I am not ready to take on that at the moment [14:35]
jonnyblunchtime here, bbl [14:39]
........ (idle for 36mn)
joined #tikiwiki [15:15]
pbiendljoined #tikiwiki [15:23]
...... (idle for 28mn)
jonnybjoined #tikiwiki [15:51]
fabriciusjoined #tikiwiki [15:55]
..... (idle for 21mn)
amette_Sexy: http://themes.getbootstrap.com/products/application
chibaguy --^
[16:16]
rludejoined #tikiwiki [16:21]
first time on IRC; would like to display tiki tracker items on a page, using tracker item id [16:26]
amette_Hi rlude, welcome! :) [16:30]
rludeHi Amette
I've only been developing in Tiki for about 6 months, and it was a new platform for me when I started. There are some things I haven't been able to do, learning on my own.
[16:31]
amette_Good stuff! I guess you know doc.tiki.org and tiki for smarties then? [16:32]
rludeYep; read the entire volume. I always read before I ask... [16:33]
amette_:) [16:33]
rludeI've created a fairly complex tiki site for the company I work for. About the only thing I haven't been able to do that I really want to do, is show a tracker item on a tiki page... [16:34]
amette_I think what you want is PluginTrackerList or PluginList, depending on how powerful/complex it should be. [16:35]
rludeOf course I can display items in the tracker, but in tracker view. But there are more things I can do on a page, if I can display a given item.
Yep, I've used the Plugin TrackerList, and PluginList.
I've got about 250 pages, and 80 trackers...
I didn't mean to sound rude when I said 'of course' I can display items in... I just meant that I know those features are available, and I do use them.
[16:35]
amette_no offense taken
But I don't read any question either.
[16:39]
rludeOK; right now I can show item records to users in tracker; view items, or from ItemList. But what I want to do is show a single Item in a wiki page view. I don't know how to point a page to the record in the tracker by tracker Item ID. [16:41]
amette_You could for example use https://doc.tiki.org/PluginTrackerList with the parameter itemId to filter for a specific item.
like so: {trackerlist trackerId="42" itemId="23"}
that would only list item 23 in tracker 42
[16:42]
rludeOK; I will try that. Is it possible to show an item by item id when clicking on the link to an Item from a TrackerList? [16:45]
amette_What do you mean by "show an item by item it"?
id even
[16:46]
rludeWell, when a tracker list is displayed, and the user can click on an Item to view it, how can I have that record (item) display in a page that is created for viewing items in the Tracker? [16:47]
amette_Scroll down on that doc.t.o page to "More information on parameters" then check the "url" tab for instructions about that. [16:48]
rludeIf I call out an Item ID in a string for a page, that is the only record (item) that will be viewed on that page. I want to view any Item the user selects. [16:48]
amette_the url parameter whould be what you are looking for
should, damn fingers
[16:49]
rludeOK
Thanks!
[16:50]
amette_You're welcome! Happy hacking! :) [16:50]
rludeYes, I think the More Info/URL is what I was looking for. Thanks again! [16:58]
amette_Cool, yw! :) [16:59]
.................... (idle for 1h36mn)
fabriciusjoined #tikiwiki [18:35]
jonnybjoined #tikiwiki [18:44]
........ (idle for 39mn)
pbiendljoined #tikiwiki [19:23]
............. (idle for 1h0mn)
fabriciusjoined #tikiwiki [20:23]
Tiki|botNew Forum Posts: 14.1 release (soon)? - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57636 [20:25]
.... (idle for 17mn)
arildbHi jonnyb [20:42]
jonnybHi arildb [20:42]
arildbI just committed a fix for the problem with non-English characters in page names while using SEFURL.
Please check
...if you have time
[20:42]
jonnybok, will have a look, thanks [20:43]
arildbThe good news is that it now works on my side. The bad new is that the problem seems to be $_SERVER['REQUEST_URI'], which is used lots of p´┐Żlaces [20:44]
jonnybso on IIS REQUEST_URI isn't utf8? [20:44]
arildbOn IIS not
I get the *** signs in php_info too
[20:45]
Tiki|botNew Forum Posts: [Tikiwiki-cvs/svn] SF.net SVN: tikiwiki:[56584] trunk - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57637 [20:45]
jonnybwell my localhost test works ok [20:47]
arildbI don't thik the conversion to ut8 should have any side effects [20:47]
jonnybbut as you say REQUEST_URI is all over the place [20:48]
arildbyes [20:48]
jonnybmaybe this SO thread has some help http://stackoverflow.com/q/4095899 [20:49]
arildbanyhow, I hope this is a fix, and it's in now before the next 14 release. So, that's good [20:50]
jonnybusing http://php.net/mb_detect_encoding to detect [20:50]
arildbTest with mb_detect_encoding. $_SERVER['REQUEST_URI'] is "ASCII" encoded on IIS [20:51]
jonnybso maybe you could convert it to utf8 if it's not detected, then it would be ok everywhere after that? [20:52]
arildbyes, good idea. [20:53]
jonnybanyway, my little test still works and i need a break (and i hate text encoding!) more later (or probably tomorrow ;) ) [20:53]
arildbmaybe in tiki-setup?
see you
[20:53]
jonnybwell route.php happens before all that [20:53]
arildbok [20:53]
jonnybhave fun! :D [20:54]
......................... (idle for 2h1mn)
Tiki|botRecent Bug: - http://dev.tiki.org/item5770 [22:55]
........... (idle for 50mn)
New Forum Posts: [Tikiwiki-cvs/svn] SF.net SVN: tikiwiki:[56584] trunk - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57637
New Forum Posts: 14.1 release (soon)? - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57636
New Forum Posts: Feedback Methods Vote - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57630
[23:45]
New Forum Posts: [Tikiwiki-cvs/svn] SF.net SVN: tikiwiki:[56584] trunk - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57637
New Forum Posts: 14.1 release (soon)? - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57636
New Forum Posts: Feedback Methods Vote - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57630
[23:55]

←Prev date Next date→ Show only urls(Click on time to select a line by its url)