WhoWhatWhen fabriciusjoined #tikiwiki [00:44] ....... (idle for 33mn)Circuitsoftjoined #tikiwiki
Hello - I'm getting a Segfault on Tiki 14 on Debian Jessie.
PHP 5.6.13-0+deb8u1 (cli) (built: Sep 7 2015 13:38:37)
Appears to be https://bugs.php.net/bug.php?id=69547
URL in question is http://internal/tiki/tiki-user_preferences.php [01:17] fabriciushello Circuitsoft [01:24] CircuitsoftAlso, the dumped core is almost 8GB. [01:27] fabriciussry, am in a phone conference. will need a while. just wanted to ping [01:27] CircuitsoftThanks. Anything further info I can get for you? [01:27] fabriciusI find the URL in question strange (the content)+ [01:27] CircuitsoftPHP always segfaults when I try to open user prefs for any user.
Does not segfault if there is no logged-in user. [01:28] fabriciuswww.internal.com/tiki/tiki-user_preferences.php is not a Tiki isn't it?
Loans
Cheapest Insurance
Credit Cards
etc. ... [01:29] CircuitsoftSorry, http://internal/ is an internal site at my company. [01:30] fabriciusok :d
:D [01:30] CircuitsoftUpgraded to tiki-14 from tiki-12.
tiki-12 was on mod_php, tiki-14 is on php-fpm via nginx [01:32] fabriciusahh nginx problem? guess amette amette__ found a solution [01:35] CircuitsoftNo idea, but why would php segfault? Especially, since everything else seems to be working. [01:37] ....... (idle for 32mn)fabricius: Has your conference finished? [02:09] ......... (idle for 44mn)Gwaynejoined #tikiwiki [02:53] .......... (idle for 47mn)fabriciusCircuitsoft: nearly
;-) [03:40] CircuitsoftOoph. Unfortunately, I need to go home for the night.
I know how I feel after having a phone on my ear for one hour. I can't imagine two.
Circuitsoft is going AFK for at least 12 hours [03:45] .......... (idle for 45mn)Tiki|botNew Forum Posts: JQ tracker issues - https://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210
New Forum Posts: empty variable post error on deleting forum posts - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57208
New Forum Posts: How to config a main menu like tiki.org/forum4 within Tikiwiki Groupware 14.x? - https://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57197 [04:31] New Forum Posts: JQ tracker issues - http://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210
New Forum Posts: empty variable post error on deleting forum posts - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57208
New Forum Posts: How to config a main menu like tiki.org/forum4 within Tikiwiki Groupware 14.x? - http://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57197 [04:41] New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212 [04:51] leagrisjoined #tikiwiki [04:57] .................................................................... (idle for 5h36mn)redflojoined #tikiwiki
joined #tikiwiki [10:33] ..... (idle for 24mn)Tiki|botjoined #tikiwiki [10:57] ........... (idle for 53mn)Jyhem_laptopjoined #tikiwiki [11:50] Jyhem_laptop_joined #tikiwiki [11:52] Tiki|botNew Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - https://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210
New Forum Posts: empty variable post error on deleting forum posts - https://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57208 [11:58] New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - http://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210
New Forum Posts: empty variable post error on deleting forum posts - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57208 [12:08] Recent Bug: - http://dev.tiki.org/item5715 [12:19] .... (idle for 15mn)fabriciusjoined #tikiwiki [12:34] Tiki|botNew Forum Posts: girl and Boy Love Vashikaran Specialist baba ji +91-9929 415910 - http://tiki.org/tiki-view_forum_thread.php?forumId=24&comments_parentId=57217
New Forum Posts: +91-9929 415910 {LONDON~AUSTRALIA~CANADA~oman~-love vashikaran specialist baba ji - http://tiki.org/tiki-view_forum_thread.php?forumId=24&comments_parentId=57216 [12:38] Gwaynejoined #tikiwiki [12:44] Tiki|botNew Forum Posts: kala jadu childless expert +91-9929415910 women/wife all love vashikaran specilist babaji - http://tiki.org/tiki-view_forum_thread.php?forumId=24&comments_parentId=57224
New Forum Posts: Girlfriend boyfriend Vashikaran+91-9929415910 mumbai all - http://tiki.org/tiki-view_forum_thread.php?forumId=24&comments_parentId=57223
New Forum Posts: cOmfOā„¯taBlE +91-9929415910 entry!link!=href@@ [12:48] Generator_joined #tikiwiki [12:58] ........... (idle for 50mn)Tiki|botNew Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210
New Forum Posts: empty variable post error on deleting forum posts - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57208 [13:48] New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - http://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210
New Forum Posts: empty variable post error on deleting forum posts - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57208 [13:58] ....... (idle for 33mn)fabriciusjoined #tikiwiki [14:31] .......... (idle for 46mn)jonnybjoined #tikiwiki
polom.polom [15:17] ..... (idle for 21mn)Tiki|botNew Forum Posts: Cannot view items in list of orphant pages behind a proxy - http://tiki.org/tiki-view_forum_thread.php?forumId=6&comments_parentId=57226 [15:38] ......... (idle for 43mn)jonnybSo Caarrie|away - if you're ever not away, i'm told you know about the bot that used to show the svn commits here but after the sf.net meltdown a few weeks ago it's borken, so would it be possible to fix it i wonder? I think it was the Tiki-KGB one... TIA [16:21] Caarrie|awayi dont run that bot
is Tiki|Log!~irclogger@ks311033.kimsufi.com Tiki-KGB is Tiki-KGB!~tiki-kgb@ks311033.kimsufi.com same owner [16:35] ....... (idle for 33mn)Tiki|botNew Forum Posts: Cannot view items in list of orphan pages behind a proxy - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=6&comments_parentId=57226
New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210 [17:08] jonnybthanks Caarrie|away - sounds like a job for Jyhem or amette then maybe, thanks [17:12] Tiki|botNew Forum Posts: Cannot view items in list of orphan pages behind a proxy - http://tiki.org/tiki-view_forum_thread.php?forumId=6&comments_parentId=57226
New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - http://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210 [17:18] ...... (idle for 28mn)fabriciusjoined #tikiwiki [17:46] Telesightjoined #tikiwiki [18:00] ..... (idle for 20mn)Circuitsoftfabricius: Still here, by any chance?
amette amette__? [18:20] fabriciushi Circuitsoft
not really time ... and not really aware what exactly was the solution for Nginx [18:25] CircuitsoftIs there a known issue with Nginx and fpm that causes massive segfaults?
At this point, I'm reasonably certain that nginx has nothing to do with it. [18:26] fabriciusCircuitsoft: I did find some forum posts and did send to two sysadmins ... amette did find a solution for his PHP - Nginx problem before, but for the other guy it was helpful ... a couple of weeks ago, so I am not really aware anymore
FPM and Nginx, YES! Exactly! [18:27] CircuitsoftI'll consider the possibility, but I don't think it's likely. With php-fpm out of process, and access to it over a FastCGI socket, I really doubt that's an issue.
Oh? [18:27] fabriciussegfault I do not know, but definitely there is a fmp - nginx problem and there seem to be workarounds
I did chat with amette in Check republic in July and with another guy a few weeks later - both discussions definitely about existing fpm-ngynx problems and solutions
it is not my special area of work, so you should try to get amette or you ask old friend google [18:28] CircuitsoftI had some issues with initial setup, but eveything else has been working smoothly since then. I'm also using nginx and fpm on another server with ModX, and there are no issues. [18:30] ...... (idle for 27mn)I have an xdebug trace leading to my segfault. Is there somewhere I can upload that for a dev to look at?
3.2M HTML, or 97k HTML.xz [18:57] jonnybhi all, Circuitsoft i've never had any luck with debugging seg-faults, and they always go away when php is updated in my experience, but if you think you've trapped a real repeatable one the add it to teh bug tracker here: https://dev.tiki.org/Make+a+wish [19:07] CircuitsoftWell, it's so repeatable in my case, that I can't imagine it hasn't been seen before. More, I'm trying to work out what's unique about my situation that makes it happen.
Any time any logged-in user goes to edit preferences, it segfaults, and the dumped core is almost 8GB. [19:10] jonnybthat's definitely not a bug in tiki i'm afraid, unless you can reproduce it on show.tiki.org
what version of php are you using? [19:11] CircuitsoftI figure not, but I'm on Debian Stable, with two security updates sinece I installed, and nothing's changed.
PHP 5.6.13-0+deb8u1 (cli) (built: Sep 7 2015 13:38:37)
PHP 5.6.13-0+deb8u1 (fpm-fcgi) (built: Sep 7 2015 13:38:29) [19:12] jonnybthat's the latest indeed
i guess it must be a nginx/php interaction thing then, afraid i never got nginx working anywhere (yet) [19:14] CircuitsoftI could help you with that. As I mentioned earlier (before you spoke up), I do have nginx/php working with ModX on another machine (actually same machine, different lxc container). [19:21] Tiki|botNew Forum Posts: Cannot view items in list of orphan pages behind a proxy - https://suite.tiki.org/tiki-view_forum_thread.php?forumId=6&comments_parentId=57226
New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - https://suite.tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - https://suite.tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210 [19:30] jonnybthanks Circuitsoft - might get round to it one day but unlikley to be any time soon... [19:30] xavidpjoined #tikiwiki
Circuit [19:36] jonnybpolom xavidp [19:37] xavidpCircuitsoft, tiki-user_preferences.php is part of Tiki indeed...
...but it should show spam or similar...
Hi jonnyb
xavidp using irc from mobile ("some say cell") phone [19:37] jonnyb:) [19:38] xavidpxavidp not used to tiny keyboard and no tab to autocomplete names [19:39] jonnybit's a hard life! [19:39] Circuitsoftxavidp: Have you tried HAcker's Keyboard (I assume Android)? [19:39] xavidpRe: https://irc.tiki.org/irclogger_log/tikiwiki?date=2015-09-23,Wed&sel=14#l10 [19:40] Tiki|botNew Forum Posts: Cannot view items in list of orphan pages behind a proxy - http://tiki.org/tiki-view_forum_thread.php?forumId=6&comments_parentId=57226
New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - http://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210 [19:40] CircuitsoftOh. I said I was getting the error at url http://internal/tiki/... and his browser expanded that to http://www.internal.com/ which is a cybersquatter. [19:41] xavidpCircuitsoft: not yet (android, yes)
Ah, ok.... And no redirection from other tiki urls?
xavidp confused [19:41] CircuitsoftIt's an intranet site.
He thought he could look at it, until I pointed out that he couldn't.
Either way, Whenever I visit tiki-user_preferences.php from a logged-in user, php-fpm (behind nginx) segfaults and dumps a nearly 8GB core.
I installed xdebug and got a trace from the error. I see no huge jumps in memory use anywhere, but I may just not be noticing right. [19:43] xavidpI would advise you to fill in a bug report, just in case
In caae the issue shows up to other people later than today, so that you can all share info on how to reprodice, fix, etc.
xavidp running out of battery... And housework (baby feeding in short)
C u all [19:44] jonnyboff now too - more fun tomorrow! [19:56] .... (idle for 17mn)Tiki|botRecent Bug: - http://dev.tiki.org/item5716 [20:13] .... (idle for 18mn)New Forum Posts: Cannot view items in list of orphan pages behind a proxy - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=6&comments_parentId=57226
New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - http://suite.tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210 [20:31] New Forum Posts: Cannot view items in list of orphan pages behind a proxy - http://tiki.org/tiki-view_forum_thread.php?forumId=6&comments_parentId=57226
New Forum Posts: Wiki syntax inside HTML plugin suddenly not working at themes.t.o - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57212
New Forum Posts: JQ tracker issues - http://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=57210 [20:41] ........... (idle for 50mn)New Forum Posts: Plugin LIST too "Sticky" in 14.x? - http://tiki.org/tiki-view_forum_thread.php?forumId=26&comments_parentId=57228 [21:31] fabriciusjoined #tikiwiki [21:31] ............ (idle for 59mn)Telesightjoined #tikiwiki [22:30] CircuitsoftSo, how long do I generally have to wait for tiki.org registration? I have a bug to post. [22:35] ........... (idle for 54mn)fabriciusjoined #tikiwiki [23:29]
←Prev date Next date→ Show only urls(Click on time to select a line by its url)